Arquivo de etiquetas: WordPress 3.3

WordPress 3.3 já disponível em Português

Já está disponível a mais recente versão do WordPress – a 3.3, apelidada de “Sonny” em honra do grande saxofonista Sonny Stitt – pode descarrrega-la imediatamente ou actualizar a sua instalação, a partir do seu painel.

O WordPress foi descarregado mais de 65 milhões vezes desde a versão 3.0 e, nesta terceira iteração, foi adicionada muito funcionalidade em redor da experiência para novos utilizadores, navegação, carregamentos e importações.

Para utilizadores

Os utilizadores mais experientes vão apreciar o carregamento de media por arrastar e largar, os novos menus de navegação, a nova barra de ferramentas, o suporte melhorado para a edição colaborativa e o novo importador de Tumblr. Foi também muito pensada a experiência para pessoas sem conhecimentos prévios de WordPress. A versão 3.3 tem melhorias significativas com ponteiros de dicas para as novas funcionalidades incluídas em cada actualização, uma mensagem de boas-vindas amigável ​e guias de ajuda renovadas. Foi ainda melhorada a utilização do painel em tablets, com melhor suporte para navegação por toque.

Para programadores

Há também uma grande quantidade de novidades para developers. Recomenda-se que comece a sua exploração com a nova API do editor, a nova versão de jQuery, as novas e melhores maneiras para usar as páginas de ajuda, performance melhorada das URLs só com o título do artigo e claro, toda a lista de melhorias no Codex e no Trac.

[Fonte: Blog Ofi­cial Word­Press Por­tu­gal]

WordPress 3.3 Beta 3, já disponível em Português

Já está disponível a versão 3.3 Beta 3, em Português de Portugal. Já sabe o que tem a fazer: use uma instalação de testes, veja o que consegue estragar e reporte os erros que encontrar. Foram feitas mais de 200 modificações desde a versão Beta 2, se bem que as versões beta não adicionam novas funcionalidades – trata-se exclusivamente de corrigir erros, tornar o todo um pouco mais bonito e finalizar textos.

Como sempre, para os autores de plugins e temas, POR FAVOR, testem o vosso código nesta versão, para identificar incompatibilidades agora e não depois dos seus utilizadores actualizarem as respectivas instalações e encontrarem erros no código. Desta vez é mesmo a sério, especialmente se o vosso plugin ou tema usa jQuery. O jQuery foi actualizado para a versão 1.7, portanto não se esqueçam de verificar o vosso código nesta versão.

Como de costume:

  • Só para testes.
  • Não instale em ambientes de produção
  • Outra vez, no caso de não ter lido a linha acima: Não instale em ambientes de produção
  • Diga-nos o que achou no fórum de suporte.

[Fonte: Blog Oficial WordPress Portugal]

Está pronto para o WordPress 3.2?

O WordPress 3.2 vai ser lançado muito em breve com alterações importantes aos requisitos mínimos. Verifique já se está tudo a postos:

PHP e MySQL

A versão 3.2 precisa do PHP 5.2.4 e do MySQL 5.0. Como já mencionado há quase um ano, quando foi anunciada esta alteração, a percentagem de instalações com versões mais antigas do PHP e MySQL, é relativamente baixa. No entanto, com mais de 45 milhões de instalações WordPress, uma pequena percentagem pode mesmo assim significar muitos sites! Não seja apanhado de surpresa – verifique já se está a executar versões compatíveis do PHP e MySQL, antes de actualizar o seu WordPress para a versão 3.2.

Entre no painel da sua conta de alojamento e verifique que tem pelo menos o PHP 5.2.4 e MySQL 5.0. A maioria dos serviços de alojamento mais importantes já os suporta, mas existem mesmo assim algumas excepções. Se ainda está numa versão mais antiga, deve ser simples muda-la.

Se não sabe onde encontrar essa informação no seu serviço de alojamento ou sequer como aceder ao painel de controle do serviço, não se preocupe. Pode descobrir se está pronto para a 3.2 com o plugin Health Check. No seu painel (de WordPress), visite Plugins → Adicionar Novo e pesquise por “Health Check” (normalmente é o primeiro resultado). Instale e active o plugin, e ele logo lhe dirá se são necessárias actualizações.

Se precisar de mais ajuda, contacte o seu serviço de alojamento e use este exemplo de mensagem para lhes pedir ajuda:

O meu domínio [exemplo.com] está alojado nos vossos servidores e funciona com WordPress. Os requisitos mínimos mudaram para PHP 5.2.4 e 5.0 do MySQL e eu gostaria me ajudassem a confirmar que a configuração do meu site staisfaz esses requisitos. Se não, por estar neste momento a usar uma versões mais antigas do PHP ou do MySQL, agradecia que actualizassem ou que me indicassem como posso fazê-lo.

Se o seu serviço lhe responder que não pode actualizar para essas versões, talvez esta seja a boa altura para procurar um novo alojamento.

IE6 e browsers desactualizados

Foi também abandonado o suporte para o Internet Explorer 6, um browser com mais de 10 anos. que até a própria Microsoft deixou de suportar. A partir de agora, se aceder ao seu painel do WordPress com um browser desactualizado, ser-lhe-há apresentado um aviso. Porquê? Porque a tecnologia da web melhora, e o mesmo acontece com WordPress e com as funcionalidades que vão sendo implementandas para tirar proveito dessas melhorias. Se estiver a usar um browser desactualizado, é possível que a sua experiência esteja a ser limitada.

Assim, se o seu browser estiver desactualizado, verá uma caixa amarela no seu painel, que o avisa que uma nova versão está disponível (que pode ignorar, claro). Se estiver a usar o IE6 no entanto, a caixa é vermelha e o seu painel não funcionará correctamente. Se está preso ao IE6, porque o computador que usa é de uma empresa, biblioteca, escola ou semelhante e não pode descarregar um browser mais recente, aqui está um exemplo de mensagem que pode usar para pedir ao seu chefe/administrador/administrador de sistemas para actualizar o seu browser:

O computador que uso em [local onde usa o computador] tem instalado um browser de internet desactualizado. O Internet Explorer 6 foi criado há 10 anos, muito antes dos padrões actuais da web e não suporta aplicações modernas. Cada vez mais sites e aplicações estão a abandonar o suporte para IE6, incluindo a nova versão do WordPress. Até a Microsoft, fabricante do IE6, está em contagem decrescente para o momento em que o IE6 se tornará definitivamente obsoleto (http://www.ie6countdown.com/ para mais informações). Seria possível instalar uma versão actual do IE ou de qualquer outro browser moderno (mais informações em http://browsehappy.com)?

Bem-vindo ao futuro!